External Images Plugin not displaying HTTP images

Jimmy J. asked 8 years ago

I installed the External Images Plugin per your instructions, but it is not displaying some HTTP images from the merchant product feeds. I am running SSL on my site, so it is blocking the images that are coming from non-ssl merchant sources. Do you know how I can get around this and get the images to display properly in my merchant product feeds. I tried installing the Insecure Content Plugin for Wordpress, which seemed to help some, but did not fix all of them. Any suggestions? Thank you for your assistance.

1 Answers
Dave H. answered 8 years ago

If you have SSL on your site then unfortunately it is unavoidable that the external images plugin will not work in all cases – it will TRY and load the image through SSL e.g. https://www.externalimagedomain.com/externalimage.jpg but if that CDN or domain does not have SSL then it will fail.

There is no point trying to load it with http because users will not see it and instead get a security warning.

There are options for workarounds I could develop – e.g. if I spot you are using SSL and if loading the HTTPS image fails, I could replace that image with a locally proxied image – that would mean the image would be something like https://www.yourdomain.com/external-images/xyz.jpg and that would actually be a PHP page which would fetch the image from the external location using HTTP and then serve it up using HTTPS.

This would use up CPU on your server.

Another option would be to revert to downloading the insecure images and only keep using the external images when they are available with HTTPS.

This would use up disk space on your server.

I’m keen to hear your preferences.

Dave H. replied 8 years ago

I’m storing this link here for reference as someone has outlined the entire code needed to make the proxy: http://stackoverflow.com/questions/765779/how-to-display-non-ssl-images-on-https-connection

Your Answer

Super Speedy Plugins