You have 5892 options set to autoload.

Frans K. asked 7 years ago


Just installed the plugin.

Now it is showing You have 5892 options set to autoload.

This is too many and will be slowing down your site significantly. Contact us through our Q & A section for assistance in fixing this and we'll deploy a fix specific to your situation.

Is there anything i can do to lower this?

Kind regards


1 Answers
Dave Hilditch Staff answered 7 years ago

Ok – so you need to find out where the extra wp_options are coming from. Run this SQL command:

select left(option_name,15) option_name, count( * ) total from wp_options where autoload = ‘yes’ group by left(option_name,15) order by total desc;

To run SQL you can use the SQL Executioner plugin.

Once you’ve run the above, it’ll give you an indication of the source of the wp_options that are set to autoload. Then you know where you can delete them or switch them to autoload = ‘no’.

To delete them, run:

delete from wp_options where autoload = ‘yes’ and option_name like ‘transient%’;

Or you can just switch autoload off by using:

update wp_options set autoload = ‘wpi’ where option_name like ‘transient%’ and autoload = ‘yes’;

Note: You can set the autoload value to anything other than ‘yes’ and they will not be autoloaded, but still be available if a plugin really does need them. You can use ‘no’ but if you use ‘wpi’ or some other value it lets you revert your changes if you need to.

For example, to revert changes back:

update wp_options set autoload = ‘yes’ where autoload = ‘wpi’;

Hope this helps 🙂

Frans K. replied 7 years ago

No not yet. I have turned off all autoloads for the table options. Have read about leaving the options table below 500 lines.

Will going to investicate to turn it down.
I think it is a combination of the theme, and plugins i have tested but not using anymore.

When i have a better answer i will be back to place it.

Dave Hilditch replied 7 years ago

Any feedback on which plugins was causing the massive number of autoload options?

Frans K. replied 7 years ago

Thanx for all the information. It was not working with the injector plugin, but have changed it via mysql. Thnx again.

Your Answer

Super Speedy Plugins